![]() | PolygonNode Class |
The PolygonNode class represents flat geometry tree node.

Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The PolygonNode type exposes the following members.

Name | Description | |
---|---|---|
![]() | PolygonNode |
Initializes a new instance of the PolygonNode class.
|

Name | Description | |
---|---|---|
![]() | Contour |
Gets or sets the contour points of flat geometry.
|
![]() | IsAutomatic |
Gets a value indicating whether this geometry node was automatically generated (returns false if it was originally a user-defined part)
|

Name | Description | |
---|---|---|
![]() | AcceptVisitor |
Entry method for the visitor pattern
|
![]() | Clone |
Creates a new object that is a copy of the current instance.
|