API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PolyBeam Constructor (PolyBeamPolyBeamTypeEnum)

Initializes a new instance of the PolyBeam class by using the defined type.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public PolyBeam(
	PolyBeamPolyBeamTypeEnum polyBeamType
)

Parameters

polyBeamType
Type: Tekla.Structures.ModelPolyBeamPolyBeamTypeEnum
The type of the polybeam.
See Also