PolyBeam Class

The PolyBeam class represents a continuous beam with a contour as input.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class PolyBeam : Part

The PolyBeam type exposes the following members.

Constructors
  NameDescription
Public methodPolyBeam
Initializes a new instance of the PolyBeam class.
Public methodPolyBeam(PolyBeamPolyBeamTypeEnum)
Initializes a new instance of the PolyBeam class by using the defined type.
Top
Properties
  NameDescription
Public propertyContour
Gets or sets the contour for the polybeam.
Public propertyType
Gets the read only type of the polybeam. The default type for a new polybeam instance is beam.
Top
Methods
  NameDescription
Public methodAddContourPoint
Adds a contour point to the polybeam.
Public methodDelete
Deletes the polybeam instance with the given identifier from the model database.
(Overrides ModelObjectDelete.)
Public methodGetCenterLinePolycurve
Get centerline as polycurve
Public methodGetPolybeamCoordinateSystems
Returns a list of coordinate systems for the polybeam segments.
Public methodInsert
Inserts the polybeam into the model database. All the attributes must be set.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the existing polybeam in the model database to match the current one.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a polybeam from the model database. The identifier of the polybeam must be set.
(Overrides ModelObjectSelect.)
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           ContourPoint point = new ContourPoint(new Point(0,2000,0), null);
           ContourPoint point2 = new ContourPoint(new Point(2000,2000,0), null);
           ContourPoint point3 = new ContourPoint(new Point(0,4000,0), null);

           PolyBeam PolyBeam = new PolyBeam();

           PolyBeam.AddContourPoint(point);
           PolyBeam.AddContourPoint(point2);
           PolyBeam.AddContourPoint(point3);

           PolyBeam.Profile.ProfileString = "HEA400";
           PolyBeam.Finish = "PAINT";
           bool Result = false;
           Result = PolyBeam.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next