API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PhaseCollectionCopyTo Method

Copies the elements of the ICollection to an Array, starting at a particular Array index.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public void CopyTo(
	Array Array,
	int Index
)

Parameters

Array
Type: SystemArray
The one-dimensional Array that is the destination of the elements copied from the ICollection. The Array must have zero-based indexing.
Index
Type: SystemInt32
The zero-based index in the array at which copying begins.

Implements

ICollectionCopyTo(Array, Int32)
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when the array is null.
ArgumentOutOfRangeExceptionThrown when the index is less than zero.
ArgumentException Thrown when the array is multidimensional, or the index is equal to or greater than the length of the array, or the number of elements in the source ICollection is greater than the available space from the index to the end of the destination array.
InvalidCastException Thrown when the type of the source ICollection cannot be cast automatically to the type of the destination array.
See Also