API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PartCompareTo Method (Part)

Compares the instantiated part with another one.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool CompareTo(
	Part partToCompare
)

Parameters

partToCompare
Type: Tekla.Structures.ModelPart
The part to compare with.

Return Value

Type: Boolean
True if there are no differences, false otherwise.
Remarks
If the numbering hasn't been performed the function will also return false.
See Also