API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Part Constructor

Initializes a new instance of the Part class with default attributes.

The default values are set as follows:

  • Position = new Position();
  • Profile = new Profile();
  • Material = new Material();
  • DeformingData = new DeformingData();
  • Name = "";
  • Class = "";
  • Finish = "";
  • PartNumber = new NumberingSeries("P", 1);
  • AssemblyNumber = new NumberingSeries("A", 1);
  • CastUnitType = CastUnitTypeEnum.PRECAST;

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public Part()
See Also