![]() | Part Class |
The Part class represents a part in the model.
A part can be either a beam, a polybeam or a contour plate.

SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelPart
More...
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelPart
More...
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The Part type exposes the following members.

Name | Description | |
---|---|---|
![]() | Part |
Initializes a new instance of the Part class with default attributes.
The default values are set as follows:
|

Name | Description | |
---|---|---|
![]() | AssemblyNumber |
Gets or sets the assembly number.
Defines the numbering in the assembly sense.
|
![]() | CastUnitType |
Gets or sets the cast unit type of the part.
|
![]() | Class |
Gets or sets the class of the part.
|
![]() | DeformingData |
Gets or sets the deforming data of the part.
|
![]() | Finish |
Gets or sets the finish of the part.
|
![]() | Identifier |
The identifier of the object.
(Inherited from Object.) |
![]() | IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) |
![]() | Material |
Gets or sets the material the part is made of.
|
![]() | ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) |
![]() | Name |
Gets or sets the name of the part.
|
![]() | PartNumber |
Gets or sets the part number.
Defines the numbering in the part sense.
|
![]() | Position |
Gets or sets the part position.
Defines the way the part is positioned in the model.
|
![]() | PourPhase |
Gets or sets the pour phase of the part.
|
![]() | Profile |
Gets or sets the profile of the part.
|

Name | Description | |
---|---|---|
![]() | CompareTo(Object) |
Compares Identifiers of model objects.
(Inherited from ModelObject.) |
![]() | CompareTo(Part) |
Compares the instantiated part with another one.
|
![]() | Delete |
Deletes the instance from the model database.
(Inherited from ModelObject.) |
![]() | Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) |
![]() ![]() | GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) |
![]() | GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) |
![]() | GetAssembly |
Returns the assembly that the part belongs to.
|
![]() | GetBolts |
Returns an enumerator of all the connected bolts.
|
![]() | GetBooleans |
Returns an enumerator of all the connected boolean objects.
|
![]() | GetCenterLine | Returns the center line for the given part. |
![]() | GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) |
![]() | GetComponents |
Returns an enumerator of all the connected components, connections,
seams and details inherited from the base component.
|
![]() | GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) |
![]() | GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) |
![]() | GetDSTVCoordinateSystem |
Get DSTV coordinate system.
|
![]() | GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) |
![]() | GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) |
![]() | GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) |
![]() | GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) |
![]() | GetPartMark |
Returns the part mark.
|
![]() | GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) |
![]() | GetPours |
Returns an enumerator of all the pours that the part belongs to.
|
![]() | GetReferenceLine | Returns the reference line for the given part. |
![]() | GetReinforcements |
Returns an enumerator of all the connected reinforcements.
|
![]() | GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetSolid |
Returns the solid of the part.
|
![]() | GetSolid(FormingStates) |
Returns the solid of the part.
|
![]() | GetSolid(SolidSolidCreationTypeEnum) |
Returns the solid of the part.
|
![]() | GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) |
![]() | GetSurfaceObjects |
Returns an enumerator of all the connected surface objects.
|
![]() | GetSurfaceTreatments |
Returns an enumerator of all the connected surface treatments.
|
![]() | GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) |
![]() | GetWelds |
Returns an enumerator of all the connected welds.
|
![]() | Insert |
Inserts the model object instance into the model database.
(Inherited from ModelObject.) |
![]() | Modify |
Modifies the model instance in the model database.
(Inherited from ModelObject.) |
![]() | Select |
Selects the model object instance from the model database.
(Inherited from ModelObject.) |
![]() | SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) |
![]() | SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) |
![]() | SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |

Reference

SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelPart
Tekla.Structures.ModelBeam
Tekla.Structures.ModelBentPlate
Tekla.Structures.ModelBrep
Tekla.Structures.ModelContourPlate
Tekla.Structures.ModelLoftedPlate
Tekla.Structures.ModelPolyBeam
Tekla.Structures.ModelSpiralBeam
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelPart
Tekla.Structures.ModelBeam
Tekla.Structures.ModelBentPlate
Tekla.Structures.ModelBrep
Tekla.Structures.ModelContourPlate
Tekla.Structures.ModelLoftedPlate
Tekla.Structures.ModelPolyBeam
Tekla.Structures.ModelSpiralBeam