API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Offset Class

The Offset class defines the offset value of start points and end points. The offset is the distance from the current work plane in the three global directions.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelOffset

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class Offset

The Offset type exposes the following members.

Constructors
  NameDescription
Public methodOffset
Instantiates an offset with zero distance.
Top
Properties
  NameDescription
Public propertyDx
The current object's Dx offset. This value is defined using the object's coordinate system.
Public propertyDy
The current object's Dy offset. This value is defined using the current work plane.
Public propertyDz
The current object's Dz offset. This value is defined using the current work plane.
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           Point point = new Point(0, 0, 0);
           Point point2 = new Point(1000, 0, 0);

           Beam beam = new Beam(point, point2);

           beam.StartPointOffset.Dx = 105.0;
           beam.StartPointOffset.Dy = 205.0;
           beam.StartPointOffset.Dz = 305.0;

           beam.EndPointOffset.Dx = 405.0;
           beam.EndPointOffset.Dy = 505.0;
           beam.EndPointOffset.Dz = 605.0;

           beam.Profile.ProfileString = "HEA400";
           beam.Finish = "PAINT";

           bool result = false;
           result = beam.Insert();
       }
}
See Also