API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ModelObjectSelectorGetObjectsByFilter Method

Returns an enumerator of the model objects in the current model selected by the given selection filter definition.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public ModelObjectEnumerator GetObjectsByFilter(
	FilterExpression FilterExpression
)

Parameters

FilterExpression
Type: Tekla.Structures.FilteringFilterExpression
The definition of a selection filter to apply.

Return Value

Type: ModelObjectEnumerator
A model object enumerator of the objects selected by the filter.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.