API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ModelObjectSelectorGetEnumerator Method

Returns an enumerator of all the model objects in the current model.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public ModelObjectEnumerator GetEnumerator()

Return Value

Type: ModelObjectEnumerator
A model object enumerator of all the model objects.
See Also