API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ModelObjectSelectorGetAllObjectsWithType Method (Type)

Returns an enumerator of all the model objects in the current model with the given base type.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public ModelObjectEnumerator GetAllObjectsWithType(
	Type[] TypeFilter
)

Parameters

TypeFilter
Type: SystemType
The types of the objects to return.

Return Value

Type: ModelObjectEnumerator
A model object enumerator of all the model objects with the given types.
Examples
In the following example a connection to the Tekla Structures model is established and all parts and boolean objects are fetched for enumeration from the model.
using Tekla.Structures.Model;

public class Example
{
       public void Example1()
       {
           Model Model = new Model();

           System.Type[] Types = new System.Type[2];
           Types.SetValue(typeof(Part),0);
           Types.SetValue(typeof(Boolean),1);

           ModelObjectEnumerator myEnum = Model.GetModelObjectSelector().GetAllObjectsWithType(Types);
       }
}
See Also