API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ModelObjectSetUserProperty Method (String, Double)

Sets a double property for the model object.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool SetUserProperty(
	string name,
	double value
)

Parameters

name
Type: SystemString
The name of the property to be set.
value
Type: SystemDouble
The new value for the property.

Return Value

Type: Boolean
True if the property was set successfully.
See Also