API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ModelObjectGetReportProperty Method (String, String)

Retrieves a string property of the report for the model object.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool GetReportProperty(
	string name,
	ref string value
)

Parameters

name
Type: SystemString
The name of the property to be retrieved.
value
Type: SystemString
The return value.

Return Value

Type: Boolean
True if the value was returned successfully.
See Also