API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ModelObjectGetPhase Method

Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool GetPhase(
	out Phase phase
)

Parameters

phase
Type: Tekla.Structures.ModelPhase
The returned phase.

Return Value

Type: Boolean
True on success.
See Also