API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ModelObjectGetAllUserProperties Method

Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool GetAllUserProperties(
	ref Hashtable values
)

Parameters

values
Type: System.CollectionsHashtable
The return value, a hash table that contains all the values that were retrieved successfully.

Return Value

Type: Boolean
True if at least one single property was retrieved successfully.
See Also