API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ModelObjectModificationTime Property

Gets latest time of the object was modified or created.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public DateTime? ModificationTime { get; }

Return Value

Type: NullableDateTime
The date, if it was possible to retrieve it, null otherwise.
Remarks
The returned time is time of history revision which the object belongs to. For Sharing it is WriteOut time, for multiuser is save time. If history it not written then this method returns null.
See Also