API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ModelHandlerCreateNewSingleUserModel Method

Creates a new single user model.
Current model is not saved in the operation.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool CreateNewSingleUserModel(
	string ModelName,
	string ModelFolder,
	string Template = ""
)

Parameters

ModelName
Type: SystemString
The name for the new model.
ModelFolder
Type: SystemString
The folder path for the new model.
Template (Optional)
Type: SystemString
The optional template name for the new model.

Return Value

Type: Boolean
True on success.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.