API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ModelSelectModelObject Method

Takes as input an identifier to an object and then checks its type and instantiates and selects it before returning it.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public ModelObject SelectModelObject(
	Identifier ID
)

Parameters

ID
Type: Tekla.StructuresIdentifier
The identifier of the model object that is to be selected.

Return Value

Type: ModelObject
The selected model object with the given identifier, or null if object does not exists or object data loading failed for some reason.
See Also