API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LogicalWeldAddWeld Method

Adds a weld to the logical weld.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool AddWeld(
	BaseWeld Weld
)

Parameters

Weld
Type: Tekla.Structures.ModelBaseWeld
The weld to be added.

Return Value

Type: Boolean
True on success.
See Also