![]() | LogicalWeld Class |
The LogicalWeld class represents a group of welds in the model.
A logical weld contains a list of children welds.
The primary properties need to be the same in all the children welds.

SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBaseWeld
Tekla.Structures.ModelLogicalWeld
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBaseWeld
Tekla.Structures.ModelLogicalWeld
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The LogicalWeld type exposes the following members.

Name | Description | |
---|---|---|
![]() | LogicalWeld |
Creates a new logical weld instance.
|

Name | Description | |
---|---|---|
![]() | AdditionalSizeAbove | Gets or sets the additional size above for combination welds. (Inherited from BaseWeld.) |
![]() | AdditionalSizeBelow | Gets or sets the additional size below for combination welds. (Inherited from BaseWeld.) |
![]() | AngleAbove | Gets or sets the angle above. (Inherited from BaseWeld.) |
![]() | AngleBelow | Gets or sets the angle below. (Inherited from BaseWeld.) |
![]() | AroundWeld |
Gets or sets a value indicating whether
the weld is an around weld (true) or an edge weld (false).
(Inherited from BaseWeld.) |
![]() | ConnectAssemblies |
Gets or sets a value indicating whether
to connect a part or an assembly as a secondary part (false)
or as a sub-assembly (true).
(Inherited from BaseWeld.) |
![]() | ContourAbove | Gets or sets the contour above. (Inherited from BaseWeld.) |
![]() | ContourBelow | Gets or sets the contour below. (Inherited from BaseWeld.) |
![]() | EffectiveThroatAbove | Gets or sets the effective throat above. (Inherited from BaseWeld.) |
![]() | EffectiveThroatBelow | Gets or sets the effective throat below. (Inherited from BaseWeld.) |
![]() | ElectrodeClassification | Gets or sets the weld electrode classification. (Inherited from BaseWeld.) |
![]() | ElectrodeCoefficient | Gets or sets the electrode strength coefficient. (Inherited from BaseWeld.) |
![]() | ElectrodeStrength | Gets or sets the electrode strength. (Inherited from BaseWeld.) |
![]() | FinishAbove | Gets or sets the finish above. (Inherited from BaseWeld.) |
![]() | FinishBelow | Gets or sets the finish below. (Inherited from BaseWeld.) |
![]() | Identifier |
The identifier of the object.
(Inherited from Object.) |
![]() | IncrementAmountAbove |
Gets or sets the increment amount above.
(Inherited from BaseWeld.) |
![]() | IncrementAmountBelow |
Gets or sets the increment amount below.
(Inherited from BaseWeld.) |
![]() | IntermittentType |
Gets or sets the weld intermittent type.
(Inherited from BaseWeld.) |
![]() | IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) |
![]() | LengthAbove | Gets or sets the length above. (Inherited from BaseWeld.) |
![]() | LengthBelow | Gets or sets the length below. (Inherited from BaseWeld.) |
![]() | MainObject | Gets or sets the main part of the weld. (Inherited from BaseWeld.) |
![]() | ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) |
![]() | NDTInspection | Gets or sets the NDT inspection level. (Inherited from BaseWeld.) |
![]() | PitchAbove | Gets or sets the pitch above. (Inherited from BaseWeld.) |
![]() | PitchBelow | Gets or sets the pitch below. (Inherited from BaseWeld.) |
![]() | Placement |
Gets or sets the weld placement.
(Inherited from BaseWeld.) |
![]() | PrefixAboveLine | Gets or sets the size prefix above the line. (Inherited from BaseWeld.) |
![]() | PrefixBelowLine | Gets or sets the size prefix below the line. (Inherited from BaseWeld.) |
![]() | Preparation |
Gets or sets the weld preparation.
(Inherited from BaseWeld.) |
![]() | ProcessType | Gets or sets the process type. (Inherited from BaseWeld.) |
![]() | ReferenceText | Gets or sets the reference text. (Inherited from BaseWeld.) |
![]() | RootFaceAbove | Gets or sets the root face above. (Inherited from BaseWeld.) |
![]() | RootFaceBelow | Gets or sets the root face below. (Inherited from BaseWeld.) |
![]() | RootOpeningAbove | Gets or sets the root opening above. (Inherited from BaseWeld.) |
![]() | RootOpeningBelow | Gets or sets the root opening below. (Inherited from BaseWeld.) |
![]() | SecondaryObject | Gets or sets the secondary part of the weld. (Inherited from BaseWeld.) |
![]() | ShopWeld |
Gets or sets a value indicating whether
the weld is a shop weld (true) or a site weld (false).
(Inherited from BaseWeld.) |
![]() | SizeAbove | Gets or sets the size above. (Inherited from BaseWeld.) |
![]() | SizeBelow | Gets or sets the size below. (Inherited from BaseWeld.) |
![]() | Standard | Obsolete. Gets or sets the weld detail/standard. (Inherited from BaseWeld.) |
![]() | StitchWeld | Obsolete.
Gets or sets a value indicating whether
the weld is stitched (true) or not stitched (false).
(Inherited from BaseWeld.) |
![]() | TypeAbove | Gets or sets the type above. (Inherited from BaseWeld.) |
![]() | TypeBelow | Gets or sets the type below. (Inherited from BaseWeld.) |
![]() | WeldNumber | Gets the weld number. (Inherited from BaseWeld.) |
![]() | WeldNumberPrefix | Gets or sets the weld number prefix. (Inherited from BaseWeld.) |

Name | Description | |
---|---|---|
![]() | AddWeld |
Adds a weld to the logical weld.
|
![]() | CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) |
![]() | Delete |
Deletes the logical weld instance with the given identifier
from the model database and also the children welds.
(Overrides ModelObjectDelete.) |
![]() | Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) |
![]() | Explode |
Removes the logical weld from the model but not the children welds.
|
![]() ![]() | GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) |
![]() | GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) |
![]() | GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) |
![]() | GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) |
![]() | GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) |
![]() | GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) |
![]() | GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) |
![]() | GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) |
![]() | GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) |
![]() | GetMainWeld |
Returns the main weld of the logical weld.
|
![]() | GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetSolid |
Method for getting the weld solid.
(Inherited from BaseWeld.) |
![]() | GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) |
![]() | GetWeldGeometries |
Method for getting weld seam geometries.
Every result represents one individual seam geometry in current weld.
(Inherited from BaseWeld.) |
![]() | Insert |
Inserts the logical weld into the model database. All the attributes must be set.
(Overrides ModelObjectInsert.) |
![]() | Modify |
Modifies the existing logical weld in the model database to match the current one.
(Overrides ModelObjectModify.) |
![]() | RemoveWeld |
Removes a weld from the logical weld.
|
![]() | Select |
Selects a logical weld from the model database. The logical weld identifier must be set.
(Overrides ModelObjectSelect.) |
![]() | Select(BaseWeld) |
Selects the logical weld that a child weld belongs to.
|
![]() | SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) |
![]() | SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) |
![]() | SetMainWeld |
Sets the main weld for the logical weld.
|
![]() | SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |

using Tekla.Structures.Model; public class Example { public void Example1() { Weld Weld1 = new Weld(); Weld Weld2 = new Weld(); Weld1.TypeBelow = Weld.WeldTypeEnum.WELD_TYPE_SLOT; Weld2.TypeBelow = Weld.WeldTypeEnum.WELD_TYPE_SEAM; LogicalWeld LogicalWeld = new LogicalWeld(Weld1); LogicalWeld.AddWeld(Weld2); LogicalWeld.Insert(); LogicalWeld.SetMainWeld(Weld2); LogicalWeld.RemoveWeld(Weld1); LogicalWeld.Modify(); LogicalWeld.Explode(); } }