![]() | LoadUniform Class |
The LoadUniform class defines a uniformly-distributed force bounded by a polygon.

SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelLoad
Tekla.Structures.ModelLoadUniform
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelLoad
Tekla.Structures.ModelLoadUniform
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The LoadUniform type exposes the following members.

Name | Description | |
---|---|---|
![]() | LoadUniform |
Creates a new load uniform instance.
|

Name | Description | |
---|---|---|
![]() | AutomaticPrimaryAxisWeight |
The automatic primary axis weight.
(Inherited from Load.) |
![]() | BoundingBoxDx |
The dimension of the bounding box in the X direction.
(Inherited from Load.) |
![]() | BoundingBoxDy |
The dimension of the bounding box in the Y direction.
(Inherited from Load.) |
![]() | BoundingBoxDz |
The dimension of the bounding box in the Z direction.
(Inherited from Load.) |
![]() | CreateFixedSupportConditionsAutomatically |
Indicates whether fixed support conditions are created automatically.
(Inherited from Load.) |
![]() | DistanceA |
The distance a (for enlarging or reducing the loaded area).
|
![]() | FatherId |
The identifier of the father object that the load is attached to.
(Inherited from Load.) |
![]() | Group |
The load group object for the load.
(Inherited from Load.) |
![]() | Identifier |
The identifier of the object.
(Inherited from Object.) |
![]() | IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) |
![]() | LoadAttachment |
The load attachment.
(Inherited from Load.) |
![]() | LoadDispersionAngle |
The load dispersion angle.
(Inherited from Load.) |
![]() | ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) |
![]() | P1 |
The load magnitude vector.
The values are given in the local coordinate system of the load (not in the current coordinate system).
|
![]() | PartFilter |
The part filter.
(Inherited from Load.) |
![]() | PartNames |
The part names.
(Inherited from Load.) |
![]() | Polygon |
The position points for the uniform load.
|
![]() | PrimaryAxisDirection |
The vector for the primary axis direction.
(Inherited from Load.) |
![]() | Spanning |
The load spanning.
(Inherited from Load.) |
![]() | Weight |
The weight.
(Inherited from Load.) |

Name | Description | |
---|---|---|
![]() | CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) |
![]() | Delete |
Deletes the load uniform instance with the given ID from the model database.
(Overrides ModelObjectDelete.) |
![]() | Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) |
![]() ![]() | GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) |
![]() | GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) |
![]() | GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) |
![]() | GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) |
![]() | GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) |
![]() | GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) |
![]() | GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) |
![]() | GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) |
![]() | GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) |
![]() | GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) |
![]() | Insert |
Inserts the load uniform into the model database.
(Overrides ModelObjectInsert.) |
![]() | Modify |
Modifies the existing load uniform in the model database to match the current one.
At the moment it is not possible to change the load attachment or the father.
(Overrides ModelObjectModify.) |
![]() | Select |
Selects a load uniform from the model database. The ID must be set.
(Overrides ModelObjectSelect.) |
![]() | SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) |
![]() | SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) |
![]() | SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |

using Tekla.Structures.Model; using Tekla.Structures.Geometry3d; using System; public class Example { public void Example1() { LoadUniform L = new LoadUniform(); L.P1 = new Vector(1000,2000,3000); L.DistanceA = 5; L.Polygon.Points.Add(new Point(9000, 12000, 0)); L.Polygon.Points.Add(new Point(11000, 12000, 0)); L.Polygon.Points.Add(new Point(11000, 15000, 0)); L.Polygon.Points.Add(new Point(7000, 15000, 0)); L.AutomaticPrimaryAxisWeight = true; L.BoundingBoxDx = 500; L.BoundingBoxDy = 500; L.BoundingBoxDz = 500; L.LoadDispersionAngle = 3; L.PartFilter = "testing"; L.PartNames = Load.LoadPartNamesEnum.LOAD_PART_NAMES_INCLUDE; L.PrimaryAxisDirection = new Vector(1000, 500, 0); L.Spanning = Load.LoadSpanningEnum.LOAD_SPANNING_SINGLE; L.Weight = 2; L.CreateFixedSupportConditionsAutomatically = true; if (!L.Insert()) Console.WriteLine("LoadUniform Insert failed!"); } }