API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LoadGroupIncompatible Property

This variable is used to store information on which groups exclude each other in structural analysis load combination. Load combination is a process in which some simultaneously acting load groups are multiplied by their partial safety factors and combined with each other according to specific rules. To accurately combine loads which have the same load group type, you need to identify which load groups exclude each other, i.e. are incompatible. This variable stores one integer, and all groups who have this same integer are known to be incompatible with each other.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public int Incompatible { get; set; }

Property Value

Type: Int32
See Also