API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LoadGroupCompatible Property

This variable is used to store information on which groups are compatible with each other in structural analysis load combination. Load combination is a process in which some simultaneously acting load groups are multiplied by their partial safety factors and combined with each other according to specific rules. To accurately combine loads which have the same load group type, you need to identify which load groups can occur at the same time, i.e. are compatible. This variable stores one integer, and all groups who have this same integer are known to be compatible with each other. Depending on the analysis needs, they may be calculated together, in smaller combinations, or separately.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public int Compatible { get; set; }

Property Value

Type: Int32
See Also