API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

InvalidRadiusException Class

The InvalidRadiusException class represents an error when, cannot connect parts with a cylindrical section having the provided radius.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class InvalidRadiusException : ConnectiveGeometryException

The InvalidRadiusException type exposes the following members.

Constructors
  NameDescription
Public methodInvalidRadiusException
Initializes a new instance of the InvalidRadiusException class with "Cannot connect parts with a cylindrical section having the provided radius" error message.
Top
Fields
  NameDescription
Top
See Also