API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

InputItem Class

The InputItem class is used to store input objects and positions.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelInputItem

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class InputItem

The InputItem type exposes the following members.

Methods
  NameDescription
Public methodGetData
Public methodGetInputType
Returns the type of the input item.
Top
See Also