API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

IGeometryNodeVisitor Interface

The IGeometryNodeVisitor interface is implemented by classes visiting geometry nodes

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public interface IGeometryNodeVisitor
Methods
  NameDescription
Public methodVisit(SpiralNode)
Visits a node that is an instance of HelixNode
Public methodVisit(CylindricalSurfaceNode)
Visits a node that is an instance of CylindricalSurfaceNode
Public methodVisit(PolygonNode)
Visits a node that is an instance of PolygonNode node
Top
See Also