API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

IGeometryNode Interface

The IGeometryNode interface represents geometry tree node. This is implemented by concrete classes for the various types of geometry nodes

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public interface IGeometryNode

The IGeometryNode type exposes the following members.

Properties
  NameDescription
Public propertyIsAutomatic
Gets a value indicating whether this geometry node was automatically generated (i.e. false if it was originally a user-defined part)
Top
Methods
  NameDescription
Public methodAcceptVisitor
Entry method for the visitor pattern
Public methodClone
Creates a new object that is a copy of the current instance.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.