API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

HierarchicObjectAddObjects Method

Associates model objects with the hierarchical object. Fails if the hierarchical definition doesn't exist in the model.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool AddObjects(
	ArrayList Objects
)

Parameters

Objects
Type: System.CollectionsArrayList
The model objects.

Return Value

Type: Boolean
True if successful.
See Also