API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

HierarchicDefinitionRemoveObjects Method

Removes associations to the given list of hierarchical objects. Fails if the hierarchical definition doesn't exist in the model.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool RemoveObjects(
	ArrayList Objects
)

Parameters

Objects
Type: System.CollectionsArrayList
The hierarchical objects.

Return Value

Type: Boolean
True if successful.
See Also