API Reference

Detailed and full API reference helps you master Tekla development

HierarchicDefinitionAddObjects Method

Associates hierarchical objects with the hierarchical definition. Fails if the hierarchical definition doesn't exist in the model.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool AddObjects(
	ArrayList Objects
)

Parameters

Objects
Type: System.CollectionsArrayList
The hierarchical objects.

Return Value

Type: Boolean
True if successful.
See Also