![]() | HierarchicDefinition Constructor (Identifier) |
Instantiates a hierarchical definition with a known identifier. The instantiation has to be done
before the hierarchical definition instance can be selected.
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

Parameters
- ID
- Type: Tekla.StructuresIdentifier
The identifier of an existing hierarchical definition.

using Tekla.Structures.Model; using Tekla.Structures; public class Example { public void Example1() { Identifier id = new Identifier(357); HierarchicDefinition hierarchicalDefinition = new HierarchicDefinition(id); } }