API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

GridPlane Constructor (Plane, String)

Creates a new grid plane instance taking the plane and label as input.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public GridPlane(
	Plane Plane,
	string Label
)

Parameters

Plane
Type: Tekla.Structures.ModelPlane
The plane that defines the grid plane.
Label
Type: SystemString
The label for the grid plane.
See Also