API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Grid Constructor

Creates a new grid instance.

The default values are as follows:

  • Name = "Grid";
  • CoordinateX = "0.00 4*3000.00";
  • CoordinateY = "0.00 5*6000.00";
  • CoordinateZ = "0.00 6000.00 8000.00 9000.00";
  • LabelX = "A B C D E";
  • LabelY = "1 2 3 4 5 6";
  • LabelZ = "+0 +6000 +8000 +9000";
  • ExtensionLeftX = 2000.0;
  • ExtensionLeftY = 2000.0;
  • ExtensionLeftZ = 2000.0;
  • ExtensionRightX = 2000.0;
  • ExtensionRightY = 2000.0;
  • ExtensionRightZ = 2000.0;
  • IsMagnetic = false;

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public Grid()
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.