![]() | Grid Class |
The Grid class defines a user defined (possibly magnetic) set of planes helping in modeling work. A grid has grid plane
instances as children.

SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelGridBase
Tekla.Structures.ModelGrid
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelGridBase
Tekla.Structures.ModelGrid
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The Grid type exposes the following members.

Name | Description | |
---|---|---|
![]() | Grid |
Creates a new grid instance.
The default values are as follows:
|

Name | Description | |
---|---|---|
![]() | Color |
Gets or sets the color of the grid.
|
![]() | CoordinateX |
The coordinates for the X-axis.
|
![]() | CoordinateY |
The coordinates for the Y-axis.
|
![]() | CoordinateZ |
The coordinates for the Z-axis.
|
![]() | ExtensionForMagneticArea | Obsolete.
The extension for the magnetic area.
|
![]() | ExtensionLeftX |
The extension to the left X-axis.
|
![]() | ExtensionLeftY |
The extension to the left Y-axis.
|
![]() | ExtensionLeftZ |
The extension to the left Z-axis.
|
![]() | ExtensionRightX |
The extension to the right X-axis.
|
![]() | ExtensionRightY |
The extension to the right Y-axis.
|
![]() | ExtensionRightZ |
The extension to the right Z-axis.
|
![]() | FontColor |
Gets or sets font color for the grid labels
(Inherited from GridBase.) |
![]() | FontSize |
Gets or sets font size for the grid labels
(Inherited from GridBase.) |
![]() | Identifier |
The identifier of the object.
(Inherited from Object.) |
![]() | IsMagnetic |
Gets or sets whether the grid is magnetic or not.
(Inherited from GridBase.) |
![]() | IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) |
![]() | LabelX |
The labels for the X-axis.
|
![]() | LabelY |
The labels for the Y-axis.
|
![]() | LabelZ |
The labels for the Z-axis.
|
![]() | ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) |
![]() | Name |
Gets or sets the name of the grid.
(Inherited from GridBase.) |
![]() | Origin |
Gets or sets the origin of the grid
(Inherited from GridBase.) |

Name | Description | |
---|---|---|
![]() | CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) |
![]() | Delete |
Deletes the grid with the given ID.
(Inherited from GridBase.) |
![]() | Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) |
![]() ![]() | GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) |
![]() | GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) |
![]() | GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) |
![]() | GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) |
![]() | GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) |
![]() | GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) |
![]() | GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) |
![]() | GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) |
![]() | GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) |
![]() | GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) |
![]() | Insert |
Inserts the grid into the model.
(Inherited from GridBase.) |
![]() | Modify |
Modifies the grid with the given ID.
(Inherited from GridBase.) |
![]() | Select |
Selects the grid with the given ID.
(Inherited from GridBase.) |
![]() | SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) |
![]() | SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) |
![]() | SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |

using Tekla.Structures.Model; public class Example { public void Example1() { Grid Grid = new Grid(); Grid.IsMagnetic = true; bool Result = false; Result = Grid.Insert(); } }