API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

GeometrySectionEnumerator Class

The GeometrySectionEnumerator class is used to enumerate the geometry sections of a bent plate geometry.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelGeometrySectionEnumerator

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public sealed class GeometrySectionEnumerator : IEnumerator

The GeometrySectionEnumerator type exposes the following members.

Properties
  NameDescription
Public propertyCurrent
Gets the current geometry section.
Top
Methods
  NameDescription
Public methodMoveNext
Moves to the next item in the enumerator.
Public methodReset
Resets the enumerator to the beginning.
Top
See Also