API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

EventsClashDetectedDelegate Delegate

The delegate to use for clash detection. Encapsulates any method that takes a clash check data object as a parameter.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public delegate void ClashDetectedDelegate(
	ClashCheckData ClashData
)

Parameters

ClashData
Type: Tekla.Structures.ModelClashCheckData
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.