![]() | EdgeChamfer Class |
The EdgeChamfer class defines how the part edge is chamfered.

SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBoolean
Tekla.Structures.ModelEdgeChamfer
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBoolean
Tekla.Structures.ModelEdgeChamfer
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The EdgeChamfer type exposes the following members.

Name | Description | |
---|---|---|
![]() | EdgeChamfer | Initializes a new instance of the EdgeChamfer class with empty attributes. |
![]() | EdgeChamfer(Point, Point) | Initializes a new instance of the EdgeChamfer class. |

Name | Description | |
---|---|---|
![]() | Chamfer | The chamfer values for the EdgeChamfer. |
![]() | Father |
The father object of the boolean operation; the model object instance to operate on.
(Inherited from Boolean.) |
![]() | FirstBevelDimension | The bevel dimension if the first end is bevelled. |
![]() | FirstChamferEndType | The ChamferEndTypeEnum of the first end. |
![]() | FirstEnd | The start point of the EdgeChamfer. |
![]() | Identifier |
The identifier of the object.
(Inherited from Object.) |
![]() | IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) |
![]() | ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) |
![]() | Name | The name of the EdgeChamfer instance. |
![]() | SecondBevelDimension | The bevel dimension if the second end is bevelled. |
![]() | SecondChamferEndType | The ChamferEndTypeEnum of the second end. |
![]() | SecondEnd | The end point of the EdgeChamfer. |

Name | Description | |
---|---|---|
![]() | CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) |
![]() | Delete |
Deletes the edge chamfer instance with the given ID from the model database.
(Overrides ModelObjectDelete.) |
![]() | Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) |
![]() ![]() | GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) |
![]() | GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) |
![]() | GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) |
![]() | GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) |
![]() | GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) |
![]() | GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) |
![]() | GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) |
![]() | GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) |
![]() | GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) |
![]() | GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) |
![]() | Insert | Inserts the edge chamfer into the model database. All the attributes must be set. (Overrides ModelObjectInsert.) |
![]() | Modify |
Modifies the existing edge chamfer in the model database to match the current one.
(Overrides ModelObjectModify.) |
![]() | Select | Selects an edge chamfer from the model database. The edge chamfer ID must be set. (Overrides ModelObjectSelect.) |
![]() | SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) |
![]() | SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) |
![]() | SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |

using Tekla.Structures.Model; using Tekla.Structures.Geometry3d; public class Example { public void Example1() { Point Point = new Point(0, 0, 0); Point Point2 = new Point(1000, 0, 0); Beam Beam = new Beam(); Beam.StartPoint = Point; Beam.EndPoint = Point2; Beam.Profile.ProfileString = "400*400"; Beam.Finish = "PAINT"; Beam.Insert(); EdgeChamfer EdgeChamfer = new EdgeChamfer(new Point(0, -100, 0), new Point(0, 200, 0)); EdgeChamfer.FirstChamferEndType = EdgeChamfer.ChamferEndTypeEnum.BEVELLED; EdgeChamfer.FirstBevelDimension = 50; EdgeChamfer.Chamfer.X = 20; EdgeChamfer.Chamfer.Y = 20; EdgeChamfer.Father = Beam; EdgeChamfer.Insert(); } }