![]() | EdgeChamfer Class |
The EdgeChamfer class defines how the part edge is chamfered.

SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBoolean
Tekla.Structures.ModelEdgeChamfer
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBoolean
Tekla.Structures.ModelEdgeChamfer
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The EdgeChamfer type exposes the following members.

Name | Description | |
---|---|---|
![]() | EdgeChamfer | Initializes a new instance of the EdgeChamfer class with empty attributes. |
![]() | EdgeChamfer(Point, Point) | Initializes a new instance of the EdgeChamfer class. |

Name | Description | |
---|---|---|
![]() | Chamfer | The chamfer values for the EdgeChamfer. |
![]() | FirstBevelDimension | The bevel dimension if the first end is bevelled. |
![]() | FirstChamferEndType | The ChamferEndTypeEnum of the first end. |
![]() | FirstEnd | The start point of the EdgeChamfer. |
![]() | Name | The name of the EdgeChamfer instance. |
![]() | SecondBevelDimension | The bevel dimension if the second end is bevelled. |
![]() | SecondChamferEndType | The ChamferEndTypeEnum of the second end. |
![]() | SecondEnd | The end point of the EdgeChamfer. |

Name | Description | |
---|---|---|
![]() | Delete |
Deletes the edge chamfer instance with the given ID from the model database.
(Overrides ModelObjectDelete.) |
![]() | Insert | Inserts the edge chamfer into the model database. All the attributes must be set. (Overrides ModelObjectInsert.) |
![]() | Modify |
Modifies the existing edge chamfer in the model database to match the current one.
(Overrides ModelObjectModify.) |
![]() | Select | Selects an edge chamfer from the model database. The edge chamfer ID must be set. (Overrides ModelObjectSelect.) |

using Tekla.Structures.Model; using Tekla.Structures.Geometry3d; public class Example { public void Example1() { Point Point = new Point(0, 0, 0); Point Point2 = new Point(1000, 0, 0); Beam Beam = new Beam(); Beam.StartPoint = Point; Beam.EndPoint = Point2; Beam.Profile.ProfileString = "400*400"; Beam.Finish = "PAINT"; Beam.Insert(); EdgeChamfer EdgeChamfer = new EdgeChamfer(new Point(0, -100, 0), new Point(0, 200, 0)); EdgeChamfer.FirstChamferEndType = EdgeChamfer.ChamferEndTypeEnum.BEVELLED; EdgeChamfer.FirstBevelDimension = 50; EdgeChamfer.Chamfer.X = 20; EdgeChamfer.Chamfer.Y = 20; EdgeChamfer.Father = Beam; EdgeChamfer.Insert(); } }