API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DetailSetReferencePoint Method

Sets the reference point; the point the user would pick for the detail to appear to.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool SetReferencePoint(
	Point ReferencePoint
)

Parameters

ReferencePoint
Type: Tekla.Structures.Geometry3dPoint
The reference point.

Return Value

Type: Boolean
True on success.
See Also