![]() | DeformingData Class |
The DeformingData class holds information about the deforming of parts.
Deformed parts are parts that have been warped, cambered or shortened.

Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The DeformingData type exposes the following members.

Name | Description | |
---|---|---|
![]() | DeformingData |
Instantiates a deforming data instance.
|

Name | Description | |
---|---|---|
![]() | Angle |
The angle of the part at its start point, relative to the part reference line.
For example, if the beam is warped 45 degrees at the end point, in the Angle field the value is 0, and the value is 45 in the Angle2 field. |
![]() | Angle2 |
The angle of the part at its end point, relative to the part reference line.
For example, if the beam is warped 45 degrees at the end point, in the Angle field the value is 0, and the value is 45 in the Angle2 field. |
![]() | Cambering |
The degree of cambering.
|
![]() | Shortening |
The degree of shortening.
|

The following example inserts a deformed beam:
using Tekla.Structures.Model; public class Example { public void Example1() { Beam MyBeam = new Beam(); MyBeam.DeformingData.Angle = 0.0; MyBeam.DeformingData.Angle2 = 45.00; MyBeam.DeformingData.Cambering = 10.0; MyBeam.DeformingData.Shortening = 20.0; MyBeam.Insert(); } }