API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CylindricalSurfaceNode Constructor

Initializes a new instance of the CylindricalSurfaceNode class.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public CylindricalSurfaceNode(
	CylindricalSurface surface
)

Parameters

surface
Type: Tekla.Structures.ModelCylindricalSurface
The contour of the node.
See Also