API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CylindricalSurfaceNode Class

The CylindricalSurfaceNode class represents cylindrical surface geometry tree node.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class CylindricalSurfaceNode : BendSurfaceNode

The CylindricalSurfaceNode type exposes the following members.

Constructors
  NameDescription
Public methodCylindricalSurfaceNode
Initializes a new instance of the CylindricalSurfaceNode class.
Top
Properties
  NameDescription
Public propertyIsAutomatic
Gets a value indicating whether this geometry node was automatically generated (returns false if it was originally a user-defined part)
(Inherited from BendSurfaceNode.)
Public propertySurface
Gets the cylindrical surface geometry.
Top
Methods
See Also