API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CustomPartSetInputPositions Method

Sets the start and end point of the custom part.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool SetInputPositions(
	Point StartPoint,
	Point EndPoint
)

Parameters

StartPoint
Type: Tekla.Structures.Geometry3dPoint
The start point of the custom part.
EndPoint
Type: Tekla.Structures.Geometry3dPoint
The end point of the custom part.

Return Value

Type: Boolean
True on success.
See Also