API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CustomPartGetStartAndEndPositions Method

Returns the start and end points of the custom part.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool GetStartAndEndPositions(
	ref Point StartPoint,
	ref Point EndPoint
)

Parameters

StartPoint
Type: Tekla.Structures.Geometry3dPoint
The start point of the custom part.
EndPoint
Type: Tekla.Structures.Geometry3dPoint
The end point of the custom part.

Return Value

Type: Boolean
True on success.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.