API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ControlPoint Constructor (Point)

Initializes a new instance of the ControlPoint class with an existing point.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public ControlPoint(
	Point existPoint
)

Parameters

existPoint
Type: Tekla.Structures.Geometry3dPoint
An existing point
See Also