API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ControlLineControlLineColorEnum Enumeration

The different line colors.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public enum ControlLineColorEnum
Members
  Member nameValueDescription
YELLOW_RED-1 The yellow/red color.
BLACK0 The black color.
WHITE1 The white color.
RED2 The red color.
GREEN3 The green color.
BLUE4 The blue color.
CYAN5 The cyan color.
YELLOW6 The yellow color.
MAGENTA7 The magenta color.
See Also