API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ControlLine Constructor (LineSegment, Boolean)

Creates a new control line instance taking the line segment and magnetism as input.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public ControlLine(
	LineSegment Line,
	bool IsMagnetic
)

Parameters

Line
Type: Tekla.Structures.Geometry3dLineSegment
The line segment to be used.
IsMagnetic
Type: SystemBoolean
Determines whether the line is magnetic or not.
See Also