API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ControlCircle Constructor (Point, Point, Point)

Initializes a new instance of the ControlCircle class. The control circle is not magnetic.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public ControlCircle(
	Point point1,
	Point point2,
	Point point3
)

Parameters

point1
Type: Tekla.Structures.Geometry3dPoint
The first point to be used.
point2
Type: Tekla.Structures.Geometry3dPoint
The second point to be used.
point3
Type: Tekla.Structures.Geometry3dPoint
The third point to be used.
See Also