API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ContourPoint Constructor (Point, Chamfer)

Creates a new contour point using the given point and chamfer.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public ContourPoint(
	Point P,
	Chamfer C
)

Parameters

P
Type: Tekla.Structures.Geometry3dPoint
The point (with X, Y and Z coordinates) to be used.
C
Type: Tekla.Structures.ModelChamfer
The chamfer to be used.
See Also