![]() | ContourPoint Class |
The ContourPoint class defines a point with possible chamfering information,
used, for example, to define a contour plate.

Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The ContourPoint type exposes the following members.

Name | Description | |
---|---|---|
![]() | ContourPoint |
Creates a new contour point instance.
|
![]() | ContourPoint(Point, Chamfer) |
Creates a new contour point using the given point and chamfer.
|


Name | Description | |
---|---|---|
![]() | CompareTo |
Compares two points. To use binarysearch somekind of sorting should be used.
(Inherited from Point.) |
![]() | Equals |
Returns true if the current object and the given object are equal.
(Inherited from Point.) |
![]() | GetHashCode |
Returns a hash code for the point.
Notice, in extremely rare cases, you might not get the same
hash code for two points even though they are considered equal! This
should, however, happen only in extremely rare cases!
(Inherited from Point.) |
![]() | SetPoint |
Sets the point's coordinates for the contour point.
|
![]() | ToString |
Formats the point into a string.
(Inherited from Point.) |
![]() | Translate |
Translates the point using the given vector.
(Inherited from Point.) |
![]() | Zero |
Zeros all the members of the point.
(Inherited from Point.) |

Name | Description | |
---|---|---|
![]() | X |
The X-coordinate of the point.
(Inherited from Point.) |
![]() | Y |
The Y-coordinate of the point.
(Inherited from Point.) |
![]() | Z |
The Z-coordinate of the point.
(Inherited from Point.) |