API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ContourCalculatePolygon Method

Calculate a polygon approximating the contour with chamfers evaluated.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool CalculatePolygon(
	out Polygon polygon
)

Parameters

polygon
Type: Tekla.Structures.ModelPolygon
The calculated Polygon.

Return Value

Type: Boolean
True if successful, otherwise false.
See Also